How to configure Summery Routes in Cisco Router(i.e. Eigrp,Ospf and Rip)

0

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1st Eigrp Router:

Eigrp-2#

spanning-tree portfast default

interface GigabitEthernet0/0
ip address 192.168.8.1  255.255.255.0

interface Serial0/0/1
ip address 192.168.7.1  255.255.255.0
clock rate 64000

router eigrp 10
network 192.168.7.0
network 192.168.8.0
auto-summary

2nd Eigrp Router:

Eigrp-1#

spanning-tree portfast default

interface GigabitEthernet0/0
ip address 192.168.0.1  255.255.255.0

interface Serial0/0/0
ip address 192.168.7.2  255.255.255.0

interface Serial0/0/1
ip address 192.168.1.1 255.255.255.0

router eigrp 10
network 192.168.0.0
network 192.168.1.0
network 192.168.7.0
auto-summary

1st Ospf Router:

OSPF-2#

spanning-tree portfast default

interface GigabitEthernet0/0
ip address 192.168.10.1 255.255.255.0

interface Serial0/0/1
ip address 192.168.9.1 255.255.255.0

router ospf 100
log-adjacency-changes
network 192.168.9.0 0.0.0.255 area 1
network 192.168.10.0 0.0.0.255 area 1

2nd Ospf Router:

OSPF-1#

spanning-tree portfast default

interface GigabitEthernet0/0
ip address 192.168.4.1 255.255.255.0

interface Serial0/0/0
ip address 192.168.9.2 255.255.255.0
clock rate 64000

interface Serial0/0/1
ip address 192.168.2.1 255.255.255.0
clock rate 64000

router ospf 100
network 192.168.2.0 0.0.0.255 area 1
network 192.168.4.0 0.0.0.255 area 1
network 192.168.9.0 0.0.0.255 area 1

1st Rip Router:

RIP-1#

spanning-tree portfast default

interface GigabitEthernet0/0
ip address 192.168.12.1 255.255.255.0

interface Serial0/0/1
ip address 192.168.11.1 255.255.255.0
clock rate 64000

router rip
network 192.168.11.0
network 192.168.12.0

2nd Rip Router:

RIP-2#

spanning-tree portfast default

interface GigabitEthernet0/0
ip address 192.168.6.1 255.255.255.0

interface Serial0/0/0
ip address 192.168.11.2 255.255.255.0

interface Serial0/0/1
ip address 192.168.3.1 255.255.255.0
clock rate 64000

router rip
network 192.168.3.0
network 192.168.6.0
network 192.168.11.0

CORE-R/W# Core Router Which translates all type’s of Routing Protocol & Summarize among them. Here following Configure steps.

CORE-R/W#

spanning-tree portfast default

interface Serial0/0/0                          (1st connection to Eigrp Router)
ip address 192.168.1.2 255.255.255.0
clock rate 64000

interface Serial0/0/1                         (2nd connection to Rip Router)
ip address 192.168.3.2 255.255.255.0

interface Serial0/1/1                          (3rd connection to Ospf Router)
ip address 192.168.2.2 255.255.255.0

router eigrp 10
redistribute rip metric 10000 0 255 1 1500
redistribute ospf 100 metric 10000 100 255 1 1500
network 192.168.1.0
no auto-summary

router ospf 100
redistribute rip metric 1 subnets
redistribute eigrp 10 metric 1 subnets
network 192.168.2.0 0.0.0.255 area 1

router rip
redistribute eigrp 10 metric 1
redistribute ospf 100 metric 1
network 192.168.3.0

 

Thank You All.

Best Of Luck

 

 

 

 

 

 

 

 

 

 

Share.

About Author

shishirbd01

Leave A Reply

Powered by themekiller.com