Summary route:-Bgp,Ospf,Eigrp&Static

0

Configuring Steps:-

bgp,ospf,Eigrp,static

 

 

 

 

 

 

 

 

 

 

Static-R/W02:-

interface GigabitEthernet0/0

ip address 192.168.10.1 255.255.255.0

interface Serial0/0/1

ip address 192.168.6.1 255.255.255.0

clock rate 64000

 

ip route 192.168.3.0 255.255.255.0 192.168.6.2

ip route 192.168.1.0 255.255.255.0 192.168.6.2

ip route 192.168.2.0 255.255.255.0 192.168.6.2

ip route 192.168.4.0 255.255.255.0 192.168.6.2

ip route 192.168.0.0 255.255.255.0 192.168.6.2

ip route 192.168.8.0 255.255.255.0 192.168.6.2

ip route 192.168.5.0 255.255.255.0 192.168.6.2

ip route 192.168.9.0 255.255.255.0 192.168.6.2

ip route 192.168.7.0 255.255.255.0 192.168.6.2

ip route 192.168.11.0 255.255.255.0 192.168.6.2

 

Static-R/W01:-

interface Serial0/0/0

ip address 192.168.6.2 255.255.255.0

interface Serial0/0/1

ip address 192.168.3.1 255.255.255.0

clock rate 64000

 

ip route 192.168.10.0 255.255.255.0 192.168.6.1

ip route 192.168.1.0 255.255.255.0 192.168.3.2

ip route 192.168.2.0 255.255.255.0 192.168.3.2

ip route 192.168.4.0 255.255.255.0 192.168.3.2

ip route 192.168.0.0 255.255.255.0 192.168.3.2

ip route 192.168.8.0 255.255.255.0 192.168.3.2

ip route 192.168.5.0 255.255.255.0 192.168.3.2

ip route 192.168.9.0 255.255.255.0 192.168.3.2

ip route 192.168.7.0 255.255.255.0 192.168.3.2

ip route 192.168.11.0 255.255.255.0 192.168.3.2

 

Eigrp-R/W02:-

interface GigabitEthernet0/0

ip address 192.168.8.1 255.255.255.0

interface Serial0/0/1

ip address 192.168.0.1 255.255.255.0

clock rate 64000

 

router eigrp 10

network 192.168.0.0

network 192.168.8.0

 

Eigrp-R/W01:-

interface Serial0/0/0

ip address 192.168.0.2 255.255.255.0

interface Serial0/0/1

ip address 192.168.1.1 255.255.255.0

router eigrp 10

network 192.168.0.0

network 192.168.1.0

Ospf-R/W01:-

interface Serial0/0/0

ip address 192.168.5.1 255.255.255.0

interface Serial0/0/1

ip address 192.168.2.1 255.255.255.0

clock rate 64000

router ospf 100

network 192.168.5.0 0.0.0.255 area 1

network 192.168.2.0 0.0.0.255 area 1

Ospf-R/WE02:-

interface GigabitEthernet0/1

ip address 192.168.9.1 255.255.255.0

interface Serial0/0/0

ip address 192.168.5.2 255.255.255.0

 

router ospf 100

network 192.168.5.0 0.0.0.255 area 1

network 192.168.9.0 0.0.0.255 area 1

Bgp-R/W01:-

interface Serial0/0/0

ip address 192.168.4.1 255.255.255.0

clock rate 64000

interface Serial0/0/1

ip address 192.168.7.1 255.255.255.0

clock rate 64000

 

router bgp 150

neighbor 192.168.7.2 remote-as 160

neighbor 192.168.4.2 remote-as 170

network 192.168.4.0

network 192.168.7.0

Bgp-R/W02:-

interface GigabitEthernet0/1

ip address 192.168.11.1 255.255.255.0

interface Serial0/0/0

ip address 192.168.7.2 255.255.255.0

router bgp 160

neighbor 192.168.7.1 remote-as 150

network 192.168.7.0

network 192.168.11.0

Core-R/W:-

interface Serial0/0/0

ip address 192.168.1.2 255.255.255.0

interface Serial0/0/1

ip address 192.168.4.2 255.255.255.0

interface Serial0/1/0

ip address 192.168.2.2 255.255.255.0

interface Serial0/1/1

ip address 192.168.3.2 255.255.255.0

 

router eigrp 10

redistributeospf 100 metric 10000 100 255 1 1500

redistributebgp 170 metric 10000 100 255 1 1500

redistribute static metric 10000 100 255 1 1500

network 192.168.1.0

no auto-summary

 

router ospf 100

log-adjacency-changes

redistributeeigrp 10 metric 1 subnets

redistributebgp 170 metric 1 subnets

redistribute static metric 1 subnets

network 192.168.2.0 0.0.0.255 area 1

 

router bgp 170

neighbor 192.168.4.1 remote-as 150

network 192.168.4.0

redistributeeigrp 10

redistributeospf 100

redistribute static

ip route 192.168.6.0 255.255.255.0 192.168.3.1

ip route 192.168.10.0 255.255.255.0 192.168.3.1

It will work.

Thank You all.

Share.

About Author

shishirbd01

Leave A Reply

Powered by themekiller.com